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What’s new in version 2.1.2 ?

The following new features are available in ART-Human version 2.1.2:

• Improved and corrected BVH file output

• Revised and improved C3D file output, now entirely following the C3D file format
specifications

• Support for Measurement Tool output format 6dmt2

What’s new in version 2.1.0 ?

The following new features are available in ART-Human version 2.1.0:

• Introduced output to a CSV file which can be used in RAMSIS software

• Several important bug fixes in 6dj output

What’s new in version 2.0.0 ?

Version 2.0 of ART-Human was rewritten from ground up and includes many new features
and bug fixes. Compared to version 1.x, the most important new features are:

• New and more accurate inverse kinematics solver

• More detailed spine model

• Improved calibration process

• Reworked user interface

• Full Fingertracking integration

• Real-time VRPN output

• C3D and BVH file output

• Dassault Systèmes Live Motion Standard v1 support

• New license model
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1 Introduction

1.1 What is ART-Human?

ART-Human allows an ART optical tracking system to be used for Motion Capture. ART-
Human can automatically calibrate the bone lengths of a human body model in a simple
calibration procedure to an accuracy level of one centimeter. Using advanced inverse
kinematics, the human body pose is reconstructed in real-time and visualized in 3D. The
resulting bone positions can be sent in real-time to other applications using 6dj, VRPN
or Siemens Jack interfaces or recorded to disk in, for example, C3D, BVH, and CSV
formats.

1.2 Features

The most important features of ART-Human are

• Real-time inverse kinematics solver

• Simple calibration procedure

• Support of hybrid optical-inertial tracking for better occlusion handling

• Full-body and upper-body tracking

• Full Fingertracking support

• Interfaces to RAMSIS Automotive, Siemens Jack and Dassault Systèmes Live Mo-
tion Standard v1

• Real-time output via VRPN, 6dj and Siemens Jack interfaces

• Output to C3D, BVH, and CSV files for animation and motion analysis

7



2 Main User Interface

The user interface of ART-Human consists of the views

• 3D Viewer

• Control Window

• Models Window

• Tools Window

• Display Settings

Figure 2.1: Main user interface

With the exception of the 3D Viewer, each view can be enabled or disabled from the View
menu. The views can be placed freely on the screen by drag and drop operations.

8
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2.1 3D Viewer

Options Descriptions

Frames/Second Frames per second of the output data

Number of Targets Number of active tracking targets provided by DTRACK
Models Shows the currently tracked models

Table 2.1: Displayed information in Control window.

2.1 3D Viewer

When the tracking or target display is active, the 3D Viewer shows a real-time 3D view of
the tracked models, tools and targets. The viewpoint can be moved using the following
operations:

• To move left/right and up/down, hold the left mouse button and move the mouse

• To move forward/backward , use the scroll wheel or hold both the shift key and the
left mouse button while moving the mouse up or down

• To rotate the viewing position around the scene, hold the right mouse button and
move the mouse

For a full screen view, choose View → Full Screen from the menu or press F5. If the
viewing position was accidentally moved out of the tracking volume, the position can be
reset using View → Reset View or by pressing the ESC key. The contents of the 3D
Viewer can be changed in the Display Settings view (see Section 2.5).

2.2 Control Window

Figure 2.2: Control window

The Control window is used to start and stop the tracking
process and provides some information about the cur-
rent tracking state. To start or stop the real-time inverse
kinematics tracking and activate the configured output
channel, push Tracking. When no models are calibrated,
a real-time display of the tracking targets as provided
by DTRACK (with no inverse kinematics) can be acti-
vated by pressing Display . Additional displayed informa-
tion is briefly described in Table 2.1.

9



2 Main User Interface

2.3 Models Window

Figure 2.3: Models window

The Models window shows the currently available models
and allows basic operations on the model list. By click-
ing on the arrow left of the model name, it is possible to
navigate through the bone hierarchy of each model and
view the current target assignments and bone lengths for
each calibrated bone.
To create a new model, press the button, which will
open the New Human Model dialog. You can assign the
model a name, an icon and choose the MoCap target set
to use. How to create new models is described in more
detail in Section 3.3. To delete a model , select it and
press the button.
The model calibration is started by selecting the model
and clicking on Calibrate. For more details on calibra-
tion, see Section 3.4. Manual changes to the target assignment can be reset using the

button.
A calibrated model can be saved to disk using the button. ART-Human currently
supports two formats, which can be chosen in the Save Model dialog: The human models
(∗.hm) format contains the whole hierarchy and calibration data for backup or transfer
of calibration to another computer. The segment descriptions (∗.csv) format provides a
simple method to export segment lengths for use by other programs. Note that the
segment descriptions do not contain the full hierarchy or calibration information, and thus
cannot be loaded back into ART-Human. An exported human model can be loaded from
disk using the button.

Remark Normally it is not necessary to explicitly save models except for backup or
transferring to another computer, because ART-Human automatically saves the mod-
els in the Models Window to its internal workspace and loads them on start of the
application.

To activate a model for tracking, check the box left of the model name. Only active
models will be used for inverse kinematics and output.
For target assignment , double click the Target field of the bone and enter the DTRACK
Target-ID. Special target types such as Flysticks or Measurement tools can be specified
using the naming scheme listed in Table 2.2.

Remark Normally, targets are assigned to bones automatically during calibration.
Manual assignment is only necessary when this does not work for some reason. Man-
ual target assignment can also be done in the Calibration dialog.

2.4 Tools Window

10
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2.5 Display Settings

Target IDs Body Type

01 . . . 99 DTRACK standard bodies and inertial targets

H01 . . . H99 Hand targets used by the finger tracking module

F01 . . . F99 Flysticks

M01 . . . M99 Measurement tools

Table 2.2: Naming scheme for targets

Figure 2.4: Tools window

Tools are additional tracking targets which are not used
for inverse kinematics and passed through to the out-
put channel by ART-Human. Among others, they can be
used for prop tracking and interaction devices.
Clicking on creates a new tool, while deletes the
selected tool . By double-clicking on the tool name, the
name can be changed. To assign a target , double-click
the Target field and enter the body ID. For Flysticks, mea-
surement tools, etc. use the same naming scheme as
described in Table 2.2 in Section 2.3. The buttons and
and save and load the tool name and target assign-
ment to and from a file on disk, respectively.

2.5 Display Settings

Figure 2.5: Display settings

The contents displayed in the 3D viewer can be cus-
tomized by activating and deactivating the various op-
tions in the Display Settings window. Available options
are listed below.

World Display

The following options control the display of items which
are always present in the scene:

Target IDs Body Type

Grid Shows a grid on the floor.

Coordinate System Shows the axes and origin of the current room coordinate system.

Number of Targets Shows the number of available and assigned targets.

11



2 Main User Interface

Human Model Display

The options listed in Table 2.3 control the display of the tracked models.

Target IDs Body Type

Spheres Displays the bones of the tracked model using three-dimensional
ellipsoids.

Cones Displays the bones of the tracked model as cones. In contrast to the
Spheres option, the orientation of bones can be recognized more
easily

Lines Draws straight lines between the joints of the tracked model.

Model Name Shows the name of the model next to the model’s head. Useful
when multiple models are tracked.

Segment IDs Draws the bone IDs next to each bone. Useful for debugging the
output.

Joints Draws the joint locations as spheres.

Coordinate Systems Draws a coordinate system at the origin of each bone.

Retargeted Model If activated, the retargeted model is shown, as sent to the output
channel. Otherwise, the internal representation is shown.

Table 2.3: Model Display

Target Display

The options listed in Table 2.4 control the display of DTRACK tracking targets, i.e., ART-
Human inputs.

Target IDs Body Type

Coordinate Systems Draws a coordinate system at the origin of each target.

Target IDs Draws the target ID next to each target’s location. Useful for check-
ing the target assignment.

Table 2.4: Target Display

12
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3 Creating and calibrating models

Before a model can be tracked, the following steps have to be performed.

• Setting up the DTRACK system

• Putting on the MoCap Suit

• Creating a new model

• Calibrating the model

3.1 Preparing DTRACK

For setting up the camera system and to perform an initial room calibration, please follow
the instructions given in the DTRACK3 User’s Guide.

Calibrating the Tracking Targets

To track the targets of the MoCap suit with the camera system, a body calibration of
all tracking targets must be performed in the DTRACK software once. The simplest
solution is to use the Target Library method which allows the simultaneous calibration of
all MoCap targets, even when already worn on the body. Please refer to the DTRACK3
User’s Guide for details.
In cases where body calibration using the target library is not possible (e.g., when using an
older target set or an older DTRACK version), each target must be calibrated individually
using the Custom Calibration method. We recommend calibrating using the due to
room coordinate system setting.

Remark There is no need to calibrate targets in any particular order or to assign
particular body IDs. In most cases, the correct assignment is automatically computed
during calibration.

Configuring DTRACK Output

Finally, please configure DTRACK to send the tracking data to the computer running
ART-Human. The simplest method is to run the DTRACK Frontend on the same com-
puter as ART-Human, open Settings → Output , activate an output channel and set the
destination to this computer.

13



3 Creating and calibrating models

Please also make sure that at least the fields ts and 6d are enabled. If you want to use
additional target types such as Flysticks, measurement tools or inertial bodies, please
enable the respective output fields as well.

Figure 3.1: DTRACK output settings.

Remark When using inertial targets, make sure to have the 6di field enabled. Other-
wise, inertial targets may seem to track, but ART-Human will not behave correctly in
occlusion situations.

Configuring ART-Human Input

Figure 3.2: Display settings

After configuring the output channel in DTRACK , go
back to ART-Human and open Main → Input Configu-
ration from the menu. Make sure that the DTrack UDP
port number matches the one of the DTRACK output
channel and set the ground plane to correspond to the
room calibration setting of DTRACK .

14
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3.2 Putting on the MoCap Targets

3.2 Putting on the MoCap Targets

After DTRACK is configured appropriately, please put on the tracking targets. Each target
contains a small symbol indicating where on the body it should be worn. When putting on
the target set, there are several important points to consider.

The chest and hip targets can be
worn either in front or back of the
body

The hip target is best worn in the
middle of waist, not on the left or the
right side

The foot targets should be near the
tip instead of near the ankle

Finally, walk around in the tracking volume and check if all the targets can be tracked well.

3.3 Creating a new Model

Figure 3.3: Creating new
Human model

A new model is created by pressing the button in the
Models window, which opens the New Human Model
dialog. Please enter a descriptive name and optionally
choose an icon.
Under Type of MoCap set , please choose the target set
you want to use. Currently, the following target sets are
supported.

15



3 Creating and calibrating models

• Full body (17 targets): A full body target set, consists of the following targets: hip,
chest, head, shoulders (2x), upper arms (2x), lower arms (2x), hands (2x), upper
legs (2x), lower legs (2x) and feet (2x).

• Upper body (7 targets): A simplified target set for tracking arms and head only. It
consists of the following targets: head, upper arms (2x), lower arms (2x) and hands
(2x).

Using this target set, tracking will start with the upper thoracic spine and bones
below will not be part of the output stream. Also note that this target set does
not allow tracking of the correct torso orientation and thus, the torso will always be
standing upright.

If you want to use ART-Human together with Fingertracking, please also tick the left
hand and/or right hand checkboxes. After clicking OK , the model will be created and
can be calibrated.

3.4 Calibrating a Model

To calibrate a new or existing model, first click on the model in the Models window and
then click Calibrate. Now, the Human Model Calibration dialog should open.

Target Assignment

If you want to use the automatic target assignment , please check the box Assign
Targets automatically. In this case, remove any tracking targets that do not belong to
the model from the tracking volume, so that only targets on the person are tracked by
DTRACK during calibration. Any other targets in the volume may cause the automatic
assignment to fail.
If you want to keep the current target assignment or override the assignment manually,
disable the check box and enter target IDs manually. For targets other than standard
bodies, follow the target naming scheme given in Section 2.3.

Starting the Calibration in T-Posture

To start the calibration, press Start. After a five seconds count-down, data recording
will start. At the beginning of the calibration, the person must be standing in T-Posture,
i. e., upright with arms pointing away from the body, as shown in the figure below. If
the T-Posture is not set appropriately, there will be displacements between the calculated
human model and the real motion. It is particularly important that

1. feet are parallel and standing firmly on the ground

2. hands are flat and oriented parallel to the ground

3. neck is stretched upwards

16
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3.4 Calibrating a Model

Figure 3.4: Human model calibration.

4. head is looking forward (and not to a screen standing on the side)

Joint Calibration Movement

After the data recording has started while standing in T-Posture, move all limbs until all
progress bars reach 100% in order to calibrate the bone lengths and target positions. The
calibration will automatically finish when enough motion is recorded.

17



3 Creating and calibrating models

Remark Please consider that most joints can be rotated in two or three axes and
move the limbs accordingly. Rotating all possible axes may greatly improve calibration
quality!

After the calibration has finished, push Tracking and move inside the tracking volume to
test the motions of the calibrated model. If you are not satisfied with the results, try to
calibrate again, putting extra emphasis on the motions of the body parts that did not look
correct.

18
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4 Output configurations

In order to define the output of ART-Human, open
Main → Output Configuration from the main
menu. In the Output Configuration dialog, two
separate aspects need to be configured.

• The retargeting of the model, defining the
world units, the available bones and their ori-
entations

• The actual output channel used to transmit
data to an application

In general, ART-Human allows all available options
to be combined freely; however, specific applica-
tions may require specific settings. More informa-
tion about the settings required for certain applications are given in Section 5.

4.1 Retargeting Options

ART-Human provides a number of pre-defined retargeting settings which specify the fol-
lowing aspects of the model data sent to the application.

• number of bones

• orientation of the bones

• numeric IDs of the bones

• distal or proximal bone coordinates

By clicking on the Details button, a preview of each retargeted model with target IDs and
bone orientations can be seen. The following retargeting settings are available.

4.1.1 ART-Human v2 (Default)

This default setting contains the new spine model with four spine segments. In T-pose, all
bones are oriented such that X points left, Y points backwards and Z points up. The ART-
Human v2 setting uses proximal bone coordinate systems, i. e., the origins are located
at the bone end closer to the pelvis. Please refer to Appendix A.1 for details about the
coordinate systems and bone IDs.

19



4 Output configurations

Unless required by some other application, we recommend using this setting as it most
accurately describes the result of ART-Human’s inverse kinematics.
The ART-Human v2 configuration also supports the ART finger-tracking. When finger-
tracking is activated, the orientations and positions of the finger bones are sent to the con-
figured output channel along with the ART-Human bones. Please refer to Appendix A.1
for bone IDs and to Section 5.2 for general finger-tracking settings.

4.1.2 ART-Human v1

The ART-Human v1 retargeting setting is provided for compatibility with older versions
of ART-Human. The setting uses a distal bone representation, i. e., the origin of the
bone coordinate systems is at the end of the bone that is further away from the pelvis
in T-Posture. Compared to ART-Human v2, the spine contains fewer segments and the
orientation of the right arm is changed such that the X axis points outwards. Please refer
to Appendix A.2 for details about the coordinate systems and bone IDs.

4.1.3 Siemens Jack

This retargeting setting is suitable for use with the Siemens PLM Jack software. It uses
two spine and one neck segment. The Y axis of each bone coordinate system points
along the bone in an outward direction. The Z axis points towards the front, with the
exception of the feet where it points upwards. Please refer to Appendix A.3 for details
about the coordinate systems and bone IDs.

4.1.4 Dassault Systémes Live Motion Standard v1

This retargeting setting is suitable for use with Dassault software such as 3DVIA Studio.
It uses the same spine model as ART-Human v2 but adds additional coordinates systems
for the toes (which are not tracked by ART-Human). The Y axis of each bone coordinate
system points along the bone in an outward direction. The Z axis points towards the front,
with the exception of the feet where it points upwards. Please refer to Appendix A.4 for
details about the coordinate systems and bone IDs.

4.1.5 General Retargeting Settings

ART-Human provides a number of general retargeting settings (see Table 4.1) which may
be applied to all models.

4.2 Output Channels

The output settings define the output channel that is used to send the retargeted bone
coordinates to an application. Currently, the following choices are available.

20
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4.2 Output Channels

Options Descriptions

Unit Determines the unit in which the bone positions are given. Available
choices are meters (m), centimeters (cm) and millimeters (mm).

Ground plane ART-Human can apply an extra rotation to the output data which
is configured here. Output coordinate systems are always right-
handed.

Table 4.1: General retargeting settings

4.2.1 6dj/UDP

This setting makes ART-Human send UDP packages to a client application. It extends the
standard UDP format used by DTRACK with a 6dj line that contains the 6DOF pose of
each bone in the retargeted models. Please refer to the “DTrack2 User Manual, Technical
Appendix” or “DTRACK3 Programmer’s Guide” for a general introduction to the format.
The destination IP address and UDP port of the UDP packets can be specified in the
dialog. See figure 4.1 for an example frame and table 4.2 for explanation.

fr 34514

ts 64425.076492

6d 17 [0 1.000][588.999 290.937 251.231 177.0007 -4.8196 -80.9044][0.157524

0.985378 -0.064929 0.983935 -0.162207 -0.074577 -0.084019 -0.052138 -0.995099]

[1 1.000][876.623 96.167 1300.229 6.4727 -1.0685 -159.4684][-0.936316 -0.346520

-0.056889 0.350663 -0.931247 -0.099071 -0.018648 -0.112711 0.993453] [2 1.000]

[608.793 96.403 46.564 154.4344 44.2072 -58.8099][0.371228 0.927526 -0.043426

0.613209 -0.209772 0.761558 0.697255 -0.309341 -0.646641]...

6dj 1 1 [0 21][0 1.000][535.5939 210.3112 832.9551 0.0179 -0.0045 1.3798]

[0.189832 0.981644 0.018420 -0.981806 0.189882 -0.000978 -0.004457 -0.017899

0.999830][1 1.000][473.2766 221.5040 878.6974 0.0267 0.0323 1.3811][0.188488

0.981870 0.020107 -0.981544 0.187673 0.036758 0.032318 -0.026664 0.999122][2

1.000][478.2118 217.4322 1031.2696 0.0132 -0.0466 1.3825][0.187015 0.982118

0.021679 -0.981250 0.187806 -0.043321 -0.046618 -0.013171 0.998826][3 1.000]

[471.0929 215.4209 1183.7966 0.0779 0.2727 1.3775][0.184986 0.982428 0.024828

-0.945124 0.170925 0.278433 0.269296 -0.074972 0.960135]...

Figure 4.1: Example frame for 6dj output (shortened, four separate lines)

Note that ART-Human can also pass tracking data of Flysticks and Measurement Tools
using 6df, 6df2, 6dmt, and 6dmt2 frames. Do not forget to activate necessary formats in
DTRACK output settings. Please refer to the “DTrack2 User Manual” or “DTRACK3
User’s Guide” for details.
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4 Output configurations

Line tag Description

fr Frame counter

ts Timestamp in seconds

6d nT Number of tracked standard bodies nT . For each body the ID
number IT ∈ {0, . . .}, quality value q ∈ [0, 1], position s =
(sx, sy, sz)

T ∈ R3, orientation angles η, θ, ϕ ∈ R and rotation ma-
trix b = (bij)

3,3
j=1,i=1 ∈ R3×3 is transmitted as

[IT q][sx sy sz η θ ϕ] [b11, b21, b31, b12, b22, b32, b13, b23, b33]

Please refer to the “DTrack2 User Manual, Technical Appendix” or
“DTRACK3 Programmer’s Guide” for an exact definition of orien-
tation angles and rotation matrices.

6dj nM nO Number of calibrated models nM and number of output models nO.
For each output model the ID number IM ∈ {0, . . .} and number
of retargeted bones m ∈ N is transmitted. In addition, for each
retargeted bone its pose relative to the world coordinate system is
transmitted equivalent to 6d, such that the packet has the form

[IM m]<bones>. . .

Please note that the orientation angles in 6dj are given in unit rad.

Table 4.2: 6dj message content

ART provides free sample source code (‘DTrackSDK’, available in C++ and Java) to re-
ceive and parse the output data. Please contact ART to obtain it.

4.2.2 Siemens Jack

In order to communicate with Siemens PLM Jack software select this message format
and transport channel. The Siemens Jack MCC output format opens a TCP network
connection to deliver tracking data to Jack. The destination IP address and TCP port
number of Jack can be specified. For Jack configuration details, see Section 5.3.

4.2.3 VRPN

When this output setting is activated, ART-Human opens a VRPN server to transmit re-
targeted bone poses. The local port number of the server can be specified. For each
retargeted model, a tracker is created having the same name as the model. Each bone
is represented by a sensor using the IDs specified in the retargeting settings. We recom-
mend also setting the unit settings to meter to conform to the VRPN conventions.
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4.2 Output Channels

For each defined tool, a dedicated tracker is created having the same name as the tool.
A single sensor with ID 0 transmits tool position and orientation on each tracker.

4.2.4 C3D file

For offline storage of tracking data in C3D format, please use the C3D file output setting.
Each time the tracking is started, a new file is created in the specified directory. The file-
name will include the date and time when the recording was stopped. In C3D, positions
of all bones are recorded and labeled according to the settings of the retargeter. The
orientation of bones is described using two additional “virtual markers” which are calcu-
lated as outlined in Table 4.3. Labels of these additional markers are suffixed with Y and
Z, respectively. The output of orientation can optionally be enabled for all bones or just
limbs. By ticking Use 16bit integers for 3D data the file created will store tracking data
as signed words rather than floating point numbers. To convert such data to the physical
reference system an appropriate scaling factor is calculated.

Marker-Suffix Location Example

none At origin of bone coordinate system LUAR

Y 20 mm along the y axis of the bone LUARY

Z 20 mm along the z axis of the bone LUARZ

Table 4.3: Markers and virtual markers written to C3D files. The example refers to the left
upper arm.

Each model’s marker is assigned a four letter unique abbreviation according to the bone
name given by the retargeter. E.g., LUAR depicting the Left Upper Arm, with the long
form being assigned to the marker description parameter. Each marker label uses the ab-
breviation prefixed with the model name assigned by the user, e.g., in the Model Window
(cf. Section 2.3), such that the total marker label length modelname:abbreviation does not
exceed a total of 16 characters. As a consequence, model names used with C3D output
may be truncated and are required to be unique within the first 10 characters. Marker
prefixes are managed within the SUBJECTS group.
For tools the capitalized and possibly truncated assigned name is used to label the mark-
ers. All tools are prefixed with the word Tools. There is no requirement that tool names
must be unique, however, we encourage you to choose names that can easily be distin-
guished. Please acknowledge that the tools prefix is a reserved keyword and may no be
used to name a model.

4.2.5 Biovision BVH file

For offline storage of tracking data in BVH format, please use the BVH file output setting.
Each time the tracking is started, a new file is created in the specified directory. The
filename will include the date and time when the recording was stopped. BVH files contain
the full bone hierarchy of the retargeted models. The pose of the bones is then described
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4 Output configurations

using relative angles. The generated file contains all tracked models and tools using the
names specified in the Model/Tool Windows.
If the exact position of extremities matters (and not just the joint angles), we recommend
to use the ART-Human v2 retargeting setting.

Remark As off ART-Human 2.1.2 the frame time was corrected to specify the time
between two successive frames. In previous versions this entry incorrectly contained
the frequency, i.e., the inverse of the intended meaning.

4.2.6 RAMSIS CSV file

For offline storage of tracking data in CSV format, please use the RAMSIS CSV file output
setting. Each time the tracking is started, a new file is created in the specified directory.
The filename will include the date and time when the recording was stopped. CSV files
provide positions of the bones for any chosen retargeting model. The file is structured as
follows:

Frame,<ModelName>:<BoneName>,<ModelName>:<BoneName>,. . .

For example, a file containing N frames of coordinates X, Y, Z would look like this.

0,X,Y,Z,X,Y,Z,...

1,X,Y,Z,X,Y,Z,...

...

N-1,X,Y,Z,X,Y,Z,...

A bone can be represented using a single marker or three markers using two additional
“virtual markers” similar to C3D output format, but instead of 20 mm the offset is 200
mm (see Table 4.4). If using three markers each bone appears three times that is, e.g.,
pelvis_0, pelvis_1, pelvis_2, according to Table 4.4.

Marker ID Location

0 At origin of bone coordinate system

1 200 mm along the y axis of the bone

0 200 mm along the z axis of the bone

Table 4.4: Virtual markers according to the CSV format

When the option Use 3 markers only for limbs is enabled, all the bones will be rep-
resented using a single marker, except for distal bones which do not have continuation.
When the calibrated model has no Fingertracking enabled, the bones which will be rep-
resented using three “virtual markers” are head, arms, and feet. When Fingertracking is
enabled, the arms will be represented using a single marker, as well as all finger bones,
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4.2 Output Channels

except the finger tips which will be represented using three markers. We recommend ac-
tivating this option as it greatly reduces file size and further computation time in RAMSIS.
All the tools are represented using three markers and stored after human models in CSV
file.
Note that RAMSIS does not read any header information, so you have to ignore the first
2 rows of the CSV file when importing it in RAMSIS.
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5 Working with ART-Human clients

The following section explains how to interface ART-Human with special ART tracking
targets and with 3rd party software.

5.1 ART Hybrid Optical-Inertial Targets

The ART hybrid optical-inertial motion capture targets contain wireless inertial sensors
that allow continuous motion capture even when a large part of the targets can no longer
be seen by the optical tracking cameras.
To setup inertial targets in DTRACK , follow the instructions in the DTRACK3 User’s
Guide. Do make sure that the 6di output format is enabled in the DTRACK output
settings. When 6di is not enabled, the inertial targets may seem to work, but will not
produce correct results in occlusion situations.
To use inertial targets in ART-Human, simply treat them the same way as standard targets.
ART-Human will automatically recognize the inertial functionality when the 6di output is
active.

5.2 ART Fingertracking

As of version 2, ART-Human fully integrates the ART Fingertracking system, enabling live
preview of the finger poses in the 3D viewer. Additionally, finger bone data can be sent
with the normal output channels of ART-Human.
To setup the Fingertracking and calibrate the hands in DTRACK , please follow the
instructions provided by the DTRACK3 User’s Guide. Also make sure that the gl and
glcal outputs are enabled in the DTRACK output settings.
After calibrating the hands in DTRACK , switch to ART-Human and create a new model.
In the New Model dialog, check the right hand and/or left hand boxes, depending on
which hands you want to use. The model can now be calibrated normally. If you do not
want to use the automatic target assignment, please enter H01, H02, etc. as the target IDs
for the hands.
In the ART-Human Output Settings dialog, choose the ART-Human v2 retargeting, be-
cause previous versions do not support this feature.

5.3 Siemens PLM Jack

Please also refer to the Motion Capture manual provided by Siemens PLM.
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5.3 Siemens PLM Jack

ART-Human Settings

First, follow the instructions given in section 3 to calibrate the human model until the
tracking can work normally. Then select the retargeter Siemens Jack with unit cm and
ground plane Z-X in the output configuration.

• Retargeting: Siemens Jack MCC

• Unit: cm

• Ground plane: Z-X

• Output channel: Siemens Jack MCC (TCP)

• IP address: IP address of computer running Jack

• Port: UDP or TCP port to send data to

Remark The following instructions apply to Siemens Jack software prior to version 9.

After the configuration in ART-Human, start Jack. Open Mocap Communication Port Con-
trol dialog from Modules → Motion Capture → Communication Protocol → Server
Setup. Check the port number and then Start Server . Go back to ART-Human and click
Start Tracking. If all the settings are correct, you will see the bone positions update in
the Jack Window.

Attaching Tracking Data to Jack Humans

Now stop tracking in DTRACK or stop tracking in ART-Human, to freeze the data at T-
Posture. Create a Default Female or Male Human in Jack. Right click on the human and
scale it to the correct height (Figures 5.1 and 5.2).
Open Mocap Tracking dialog from Modules → Motion Capture → Communication
Protocol → Tracking Setup. Press Add to open Tracking Setup dialog. Pick up the
Human Figure by pressing and click the mouse on the Human. Press Add Pair . Press
Constrain in the Mocap Tracking dialog and now the human is constrained to the joints
data (Figure 5.3).

Tool Tracking

In the Tool Window of ART-Human, create tools to send to Jack. Set the target ID and the
name of the tool, check the checkbox in front. Then in the tracking mode, the tool target
data will be send to Jack as the name Tools_b_toolname .

Starting and Stopping Tracking

The work routine to communicate with Jack should be:
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5 Working with ART-Human clients

Figure 5.1: Scaling of Jack manikin

Figure 5.2: Scaling settings in Jack
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5.4 Dassault 3DVIA Studio

Figure 5.3: Attaching Jack manikin to tracking data

1. Start Server in Mocap Communication Port Control

2. Start Tracking in ART-Human

3. Stop Tracking in ART-Human

4. Stop Server in Mocap Communication Port Control

Otherwise, the communication might have a problem and cause Jack to crash.

5.4 Dassault 3DVIA Studio

First, follow the instructions given in Section 3 to calibrate the human model until the
tracking can work normally. Then configure the output settings as follows:

• Retargeting: Dassault Systémes Live Motion Standard v1

• Unit: m

• Ground plane: X-Y

• Output channel: VRPN
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5 Working with ART-Human clients

3DVIA also requires the first tracked model to be named User0, the second User1, and so
forth. To connect to ART-Human from 3DVIA Studio, please follow the instructions in the
3DVIA documentation.

5.5 RAMSIS Automotive

Please also refer to the RAMSIS handbook and BodyBuilder handbook provided with the
RAMSIS installation.

ART-Human Settings

First, follow the instructions given in section 3 to calibrate the human model until the
tracking can work normally. Then configure the output settings as follows:

• Retargeting: ART-Human v2 (recommended)

• Unit: mm

• Ground plane: xy

• Output channel: RAMSIS CSV file

• Enable Use 3 markers only for limbs option (recommended)

The CSV file is created whenever a successful tracking is stopped. So, to work with
RAMSIS, create a CSV file first by starting and stopping tracking when it’s desired. Note
that RAMSIS processing of each animation frame takes considerable amount of time, so
try to keep your CSV recordings as short as possible.

Creating manikins

After the CSV file is prepared, start RAMSIS Automotive. Create a desired manikin using
Manikin → Create... menu entry. A window RAMSIS Typology appears as illustrated
on Figure 5.4. Specify the most appropriate settings for the person which was calibrated
and tracked using ART-Human.
If you have prepared correct body dimensions, load it using File → Open... menu entry,
specifying Body Dimensions as a type. Otherwise, you have to create Body Dimen-
sions file with correct values. Please, refer to BodyBuilder handbook for further explana-
tions on manikin adjustment.
Note that in principle, any RAMSIS manikin will work with our CSV output, but the less
precise body dimensions are specified, the less precise the manikin is assigned to trajec-
tories. Thus, incorrect manikin size can lead to highly imprecise results!
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5.5 RAMSIS Automotive

Figure 5.4: Create manikin in RAMSIS

Import of CSV file

After the manikin is created and its dimensions correspond to actual person tracked in
ART-Human, you can import your CSV file to RAMSIS using menu entry Animate →
Trajectories→ Import.... Specify the path to CSV file and press Open. In the next dialog
(see Figure 5.5) specify the number of frames to import and using Options... specify the
number of header lines to ignore. ART-Human generates CSV files with two-line header:
first line is the bone caption and second is the measurement unit, so 2 lines must be
ignored.
After the import of trajectories from CSV file, the RAMSIS workspace will look similarly to
Figure 5.6.

Specification of reference points

Figure 5.7: Importing reference
points in RAMSIS

Now, you have to specify reference points, i.e., the
points on RAMSIS manikin which correspond to the
position of bones in the re-targeted model (see Ap-
pendix A for the list of supported models).
As an example, if ART-Human v2 retargeting was
used in the output, and Use 3 markers only for
limbs option was enabled, we provide the reference
points file ART_V2.HPU located in \examples\RAMSIS

directory of ART-Human installation folder. To load
it, first copy provided .HPU file to RAMSIS reference-
points directory. On Windows 7 it is usually:
C:\ProgramData\RAMSIS\data\refpoints. Then,
use File → Open... menu entry as shown on Fig-
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5 Working with ART-Human clients

Figure 5.5: Import CSV file in RAMSIS

ure 5.7. This file maps bone positions of ART-
Human v2 model to corresponding joints of the
RAMSIS manikin. See also Section 4.2.6 for exact
CSV output specification.
Note, since ART-Human and RAMSIS have different
skeleton models, there is no 1:1 mapping defined. We use a quite straightforward map-
ping, which can introduce inaccuracies in the final animation. However, a user can always
move reference points as desired. Please refer to RAMSIS handbook for details on refer-
ence points.

Mapping of reference points to trajectories

Figure 5.8: Importing reference points to
trajectories in RAMSIS

After the reference points were created,
they can be mapped to imported trajecto-
ries using Animate → Animation Simu-
lator... menu entry (see RAMSIS hand-
book). For your convenience we have pre-
pared a mapping file ARTAnim.sim which
maps 31 reference points from ART_V2.HPU

file to 31 imported trajectories (see Fig-
ure 5.8).
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5.5 RAMSIS Automotive

Figure 5.6: RAMSIS Workspace after successful CSV file import

Note that you can disable the trajectories
which are not needed by double-clicking on
Active entry in Status field of animation
simulator.
The final step is to compute the animation.
In the Animation Simulator window (see
Figure 5.8) first uncheck the options Optimize Posture, Optimize Posture Sequence,
and Preadjust Manikin for better results as ART-Human already does the inverse kine-
matics. Then, specify Number of Frames to compute and press Compute button. For
further details please refer to RAMSIS handbook.
There is also a sample CSV output file with a real measurement data in the examples
directory of ART-Human which can be used for testing.
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6 License Management

ART-Human is using USB dongles for copy protection and license storage. The USB
dongle must be present on a USB port of the computer while ART-Human is running.
The USB dongles require special drivers which normally are installed by the ART-Human
setup program. In case of problems, the latest version of the drivers (CBUSetup) can be
downloaded from the Marx website1.
For licensing questions or to obtain additional licenses, please contact your ART sales
representative.

1https://www.marx.com/de/support/downloads
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A Bone IDs and Coordinate System Specifications

A.1 ART-Human v2

ID Bone Assignment

0 Pelvis

1 Lower lumbar spine

2 Upper lumbar spine

3 Lower thoracic spine

4 Upper thoracic spine

5 Neck

6 Head

7 Left shoulder

8 Left upper arm (humerus)

9 Left lower arm (radius/ula)

10 Left hand

ID Bone Assignment

11 Right shoulder

12 Right upper arm (humerus)

13 Right lower arm (radius/ula)

14 Right hand

15 Left upper leg (femur)

16 Left lower leg (fibula/tibia)

17 Left foot

18 Right upper leg (femur)

19 Right lower leg (fibula/tibia)

20 Right foot
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A.1 ART-Human v2

ART-Human v2 Fingertracking Assignment

If Fingertracking is activated, additional bones will be used to represent the state of all
finger segments. For the meaning of the segments, see the DTRACK3 User’s Guide.
Note that the coordinate system orientation of the finger segments in ART-Human is the
same as that of the corresponding hand.

ID (Left Hand) Bone Assignment ID (Right Hand)

21 – 24 Thumb root, middle, outer, tip 41 – 44

25 – 28 Index finger root, middle, outer, tip 45 – 48

29 – 32 Middle finger root, middle, outer, tip 49 – 52

33 – 36 Ring finger root, middle, outer, tip 53 – 56

37 – 40 Pinky root, middle, outer, tip 57 – 60
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A Bone IDs and Coordinate System Specifications

A.2 ART-Human v1

ID Bone Assignment

0 Pelvis (hip)

1 Lower spine (chest)

2 Upper spine (neck)

3 Head

4 Left shoulder

5 Right shoulder

6 Left upper arm (elbow)

7 Right upper arm (elbow)

8 Left lower arm (wrist)

9 Right lower arm (wrist)

ID Bone Assignment

10 Left hand

11 Right hand

12 Left hip

13 Right hip

14 Left upper leg (knee)

15 Right upper leg (knee)

16 Left lower leg (ankle)

17 Right lower leg (ankle)

18 Left foot

19 Right foot
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A.3 Siemens Jack (MCC)

A.3 Siemens Jack (MCC)

ID Bone Assignment

0 Pelvis/lower spine

1 Upper spine

2 Left upper leg

3 Left lower leg

4 Left foot

5 Left toes

6 Right upper leg

7 Right lower leg

8 Right foot

9 Right toes

ID Bone Assignment

10 Neck

11 Head

12 Left shoulder

13 Left upper arm

14 Left lower arm

15 Left hand

16 Right shoulder

17 Right upper arm

18 Right lower arm

19 Right hand
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A Bone IDs and Coordinate System Specifications

A.4 Dassault Systémes Live Motion Standard v1

ID Bone Assignment

0 Pelvis

1 Left upper leg

2 Left lower leg

3 Left foot

4 Left toe

5 Right upper leg

6 Right lower leg

7 Right foot

8 Right toe

9 Spine1

10 Spine2

11 Spine3

ID Bone Assignment

12 Spine4

13 Left Shoulder

14 Left upper arm

15 Left lower arm

16 Left Hand

17 Right Shoulder

18 Right upper arm

19 Right lower arm

20 Right Hand

21 Neck

22 Head
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